Search Windows and Linux Networking

Thursday, November 3, 2011

Configure Network With OSPF Multiple Area in Cisco Routers

 Configure Network With OSPF Multiple Area in Cisco Router

Last time we was setup single Area network with OSPF today we will setup our network Multiple Area with OSPF. see the following diagram.







Firstly we configure host name and interfaces of all Router and then configure routing 

Core 1

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Core1
Core1(config)#

Core1(config)#interface FastEthernet 0/0
Core1(config-if)#ip address 172.9.0.1 255.255.0.0
Core1(config-if)#no shutdown
Core1(config-if)#exit

Core1(config)#interface serial 0/0/0
Core1(config-if)#ip address 192.168.8.1 255.255.255.0
Core1(config-if)#no shutdown
Core1(config-if)#exit

Core1(config)#interface serial 0/0/1
Core1(config-if)#ip address 172.14.0.254 255.255.0.0
Core1(config-if)#clock rate 64000
Core1(config-if)#no shutdown
Core1(config-if)#exit

Core1(config)#interface serial 0/1/0
Core1(config-if)#ip address 192.168.7.1 255.255.255.0
Core1(config-if)#clock rate 64000
Core1(config-if)#no shutdown
Core1(config-if)#exit

Core 2

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Core2
Core2(config)#interface Serial 0/0/0
Core2(config-if)#ip address 192.168.8.2 255.255.255.0
Core2(config-if)#clock rate 64000
Core2(config-if)#no shutdown
Core2(config-if)#exit

Core2(config)#interface serial 0/1/0
Core2(config-if)#ip address 192.3.3.1 255.255.255.0
Core2(config-if)#clock rate 64000
Core2(config-if)#no shutdown
Core2(config-if)#exit

Core2(config)#interface serial 0/1/1
Core2(config-if)#ip address 192.168.4.154 255.255.255.0
Core2(config-if)#clock rate 64000
Core2(config-if)#no shutdown
Core2(config-if)#exit

Core2(config)#interface serial 0/0/1
Core2(config-if)#ip address 192.168.10.1 255.255.255.0
Core2(config-if)#clock rate 64000
Core2(config-if)#no shutdown
Core2(config-if)#exit

Core 3

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Core3

Core3(config)#interface serial 0/1/0
Core3(config-if)#ip address 172.14.0.1 255.255.0.0
Core3(config-if)#no shutdown
Core3(config-if)#exit

Core3(config)#interface serial 0/0/0
Core3(config-if)#ip address 192.168.10.2 255.255.255.0
Core3(config-if)#no shutdown
Core3(config-if)#exit

Core3(config)#interface serial 0/0/1
Core3(config-if)#ip address 192.168.9.1 255.255.255.0
Core3(config-if)#clock rate 64000
Core3(config-if)#no shutdown
Core3(config-if)#exit

Core3(config)#interface serial 0/1/1
Core3(config-if)#ip address 192.168.2.1 255.255.255.0
Core3(config-if)#clock rate 64000
Core3(config-if)#no shutdown
Core3(config-if)#exit

Core 4

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Core4

Core4(config)#interface Serial 0/0/0
Core4(config-if)#ip address 192.168.7.254 255.255.255.0
Core4(config-if)#no shutdown
Core4(config-if)#exit
Core4(config)#interface serial 0/0/1
Core4(config-if)#ip address 192.168.9.254 255.255.255.0
Core4(config-if)#no shutdown
Core4(config-if)#exit
Core4(config)#

Core4(config)#interface serial 0/1/0
Core4(config-if)#ip address 192.168.11.1 255.255.255.0
Core4(config-if)#clock rate 64000
Core4(config-if)#no shutdown
Core4(config-if)#exit

Core4(config)#interface serial 0/1/1
Core4(config-if)#ip address 192.168.12.1 255.255.255.0
Core4(config-if)#clock rate 64000
Core4(config-if)#no shutdown
Core4(config-if)#exit

Chicago

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Chicago
Chicago(config)#interface serial 0/0/0
Chicago(config-if)#ip address 192.3.3.2 255.255.255.0
Chicago(config-if)#no shutdown
Chicago(config-if)#exit

Chicago(config)#interface FastEthernet 0/0
Chicago(config-if)#ip address 192.1.1.1 255.255.255.0
Chicago(config-if)#no shutdown
Chicago(config-if)#exit

France

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname France
France(config)#interface Serial 0/0/0
France(config-if)#ip address 192.168.4.2 255.255.255.0
France(config-if)#no shutdown
France(config-if)#exit

France(config)#interface FastEthernet 0/0
France(config-if)#ip address 192.2.2.1 255.255.255.0
France(config-if)#no shutdown
France(config-if)#exit

Japan

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Japan
Japan(config)#interface serial 0/0/0
Japan(config-if)#ip address 192.168.2.254 255.255.255.0
Japan(config-if)#no shutdown
Japan(config-if)#exit

Japan(config)#interface fastEthernet 0/0
Japan(config-if)#ip address 172.10.0.1 255.255.0.0
Japan(config-if)#no shutdown
Japan(config-if)#exit

Pune

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Pune
Pune(config)#interface serial 0/0/0
Pune(config-if)#ip address 192.168.11.254 255.255.255.0
Pune(config-if)#no shutdown
Pune(config-if)#exit

Pune(config)#interface fastEthernet 0/0
Pune(config-if)#ip address 172.16.0.1 255.255.0.0
Pune(config-if)#no shutdown
Pune(config-if)#exit

Mumbai

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Mumbai
Mumbai(config-if)#ip address 192.168.12.254 255.255.255.0
Mumbai(config-if)#no shutdown
Mumbai(config-if)#exit

Mumbai(config)#interface fastEthernet 0/0
Mumbai(config-if)#ip address 172.15.0.254 255.255.0.0
Mumbai(config-if)#no shutdown
Mumbai(config-if)#exit

Next Step is to configure network Route. :-
we will configure nework route with OSPF with different area and with default route the network that are not connected to area 0. and save the configuration.



Core1

Core1(config)#router ospf 1
Core1(config-router)#do show ip int br
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        172.9.0.1       YES manual up                    up

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.8.1     YES manual up                    up

Serial0/0/1            172.14.0.254    YES manual up                    up

Serial0/1/0            192.168.7.1     YES manual up                    up

Serial0/1/1            unassigned      YES unset  administratively down down

Vlan1                  unassigned      YES unset  administratively down down
Core1(config-router)#
Core1(config-router)#network 172.9.0.0 0.0.255.255 area 0
Core1(config-router)#network 192.168.8.0 0.0.0.255 area 0
Core1(config-router)#network 172.14.0.0 0.0.255.255 area 0
Core1(config-router)#network 192.168.7.0 0.0.0.255 area 0
Core1(config-router)#exit
Core1(config)#exit
Save configuration
Core1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Core1#


Core2
Core2(config)#router ospf 1
Core2(config-router)#do show ip int br
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        unassigned      YES unset  administratively down down

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.8.2     YES manual up                    up

Serial0/0/1            192.168.10.1    YES manual up                    up

Serial0/1/0            192.3.3.1       YES manual up                    up

Serial0/1/1            192.168.4.154   YES manual up                    up

Vlan1                  unassigned      YES unset  administratively down down
Core2(config-router)#network 192.168.8.0 0.0.0.255 area 0
Core2(config-router)#network 192.168.10.0 0.0.0.255 area 0
Core2(config-router)#network 192.3.3.0 0.0.0.255 area 2
Core2(config-router)#network 192.168.4.0 0.0.0.255 area 2
Core2(config-router)#exit
Core2(config)#exit
Save Configuration 
Core2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Core2#

Core3
Core3(config)#router ospf 1
Core3(config-router)#do show ip int br
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        unassigned      YES unset  administratively down down

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.10.2    YES manual up                    up

Serial0/0/1            192.168.9.1     YES manual up                    up

Serial0/1/0            172.14.0.1      YES manual up                    up

Serial0/1/1            192.168.2.1     YES manual up                    up

Vlan1                  unassigned      YES unset  administratively down down
Core3(config-router)#
Core3(config-router)#network 192.168.10.0 0.0.0.255 area 0
Core3(config-router)#network 192.168.9.0 0.0.0.255 area 0
Core3(config-router)#network 172.14.0.0 0.0.255.255 area 0
Core3(config-router)#network 192.168.2.0 0.0.0.255 area 3
Core3(config-router)#exit
Core3(config)#exit
Save Configuration
Core3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Core3#


Core4
Core4(config)#router ospf 1
Core4(config-router)#do show ip int br
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        unassigned      YES unset  administratively down down

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.7.254   YES manual up                    up

Serial0/0/1            192.168.9.254   YES manual up                    up

Serial0/1/0            192.168.11.1    YES manual up                    up

Serial0/1/1            192.168.12.1    YES manual up                    up

Vlan1                  unassigned      YES unset  administratively down down
Core4(config-router)#
Core4(config-router)#network 192.168.7.0 0.0.0.255 area 0
Core4(config-router)#network 192.168.9.0 0.0.0.255 area 0
Core4(config-router)#network 192.168.11.0 0.0.0.255 area 1
Core4(config-router)#network 192.168.12.0 0.0.0.255 area 1
Core4(config-router)#exit
Core4(config)#exit
Save Configuration
Core4#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Core4#

Chicago
Note:- Chicago network interface is not directly connected to Area 0 so to all communicant we also configure default route along with OSPF

Chicago(config)#router ospf 1
Chicago(config-router)#do show ip int br
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        192.1.1.1       YES manual up                    up

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.3.3.2       YES manual up                    up

Serial0/0/1            unassigned      YES unset  administratively down down

Vlan1                  unassigned      YES unset  administratively down down
Chicago(config-router)#
Chicago(config-router)#network 192.1.1.0 0.0.0.255 area 2
Chicago(config-router)#network 192.3.3.0 0.0.0.255 area 2
Chicago(config-router)#exit
Chicago(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0
Chicago(config)#exit
Save Configuration
Chicago#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Chicago#

France
Note:- This network interface are also not directly connected to Area 0 so to all communicant we also configure default route along with OSPF
France(config)#router ospf 1
France(config-router)#do show ip int br
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        192.2.2.1       YES manual up                    up

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.4.2     YES manual up                    up

Serial0/0/1            unassigned      YES unset  administratively down down

Vlan1                  unassigned      YES unset  administratively down down
France(config-router)#
France(config-router)#network 192.2.2.0 0.0.0.255 area 2
France(config-router)#network 192.168.4.0 0.0.0.255 area 2
France(config-router)#exit
France(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0
France(config)#exit
Save Configuration 

France#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
France#

Japan
Note:- This network is also not directly connected to Area 0 so to all communicant we also configure default route along with OSPF 
Japan(config)#route ospf 1
Japan(config-router)#do show ip int br
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        172.10.0.1      YES manual up                    up

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.2.254   YES manual up                    up

Serial0/0/1            unassigned      YES unset  administratively down down

Vlan1                  unassigned      YES unset  administratively down down
Japan(config-router)#
Japan(config-router)#network 172.10.0.0 0.0.255.255 area 3
Japan(config-router)#network 192.168.2.0 0.0.0.255 area 3
Japan(config-router)#exit
Japan(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0
Japan(config)#
Japan(config)#exit
Save Configuration
Japan#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Japan#

Pune
Note:- This network is also not directly connected to Area 0 so to all communicant we also configure default route along with OSPF  
Pune(config)#router ospf 1
Pune(config-router)#do show ip int br
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        172.16.0.1      YES manual up                    up

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.11.254  YES manual up                    up

Serial0/0/1            unassigned      YES unset  administratively down down

Vlan1                  unassigned      YES unset  administratively down down
Pune(config-router)#
Pune(config-router)#network 172.16.0.0 0.0.255.255 area 1
Pune(config-router)#network 192.168.11.0 0.0.0.255 area 1
Pune(config-router)#exit
Pune(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0
Pune(config)#exit
Save Configuration
Pune#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Pune#

Mumbai
Mumbai(config)#router ospf 1
Mumbai(config-router)#do show ip int br
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        172.15.0.254    YES manual up                    up

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.12.254  YES manual up                    up

Serial0/0/1            unassigned      YES unset  administratively down down

Vlan1                  unassigned      YES unset  administratively down down
Mumbai(config-router)#
Mumbai(config-router)#network 172.15.0.0 0.0.255.255 area 1
Mumbai(config-router)#network 192.168.12.0 0.0.0.255 area 1
Mumbai(config-router)#exit
Mumbai(config)#exit
Save Configuration
Mumbai#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Mumbai#

It Done on Router site now go to PC and set ip address in same network and set default gateway as ip address of Router.
Next time we will see how to create VLAN in Cisco Devices.


4 comments:

  1. This comment has been removed by the author.

    ReplyDelete
  2. Dear Sir,

    *Mar 1 01:54:08.242: %OSPF-4-BADLSATYPE: Invalid lsa: Bad LSA chksum Type 3, LSID 5.5.5.0 from 6.6.6.1, 6.6.6.1, Ethernet0/0

    the above message is happen when I am trying to connect area 1 to area 0, then a router behind the ABR router show the above message and do not learn any route.

    what is problem? how to fix?

    ReplyDelete